PCPartPicker

  • Log In
  • Register

No Display and No Beeping at startup

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

kinglouis123 1 month ago

Hello PC part picker

I followed this guide. I know it is old

https://ca.pcpartpicker.com/guide/vpYcCJ/modest-amd-gaming-build?show=1#cx3174251

The only difference is that I did not install the HDD drive.

I also downgraded the graphics card to Radeon RX 570

For the power supply I used the ThermalTake TR2. 700W Bronze.

I am tried using the VGA port on the motherboard

I also tried to use HDMI that is on the graphics card.

both doesn't work.

I also tried to clear the CMOS doesn't work

One thing I noticed. The GPU fan doesn't turn and I can't power the pc off from holding the power button after 1 minute of running it.

Comments Sorted by:

FancySnancy 1 point 1 month ago

Did this pc use to work. Or is it just now made?

Did you try a different cable?

(I would say try the GPU on a different pc if you can, hoping just it's passive until a specific temp)

It's probly ganna be a psu issue judging by it not wanting to shutdown, try a different one if at all possible

kinglouis123 submitter 1 point 1 month ago

interesting So everything is new except for PSU. but PSU works for other PC plus is 750W which is more than the requirement

FancySnancy 1 point 1 month ago

If you say you've tested it recently, then I'm not sure what the problem is

kinglouis123 submitter 1 point 1 month ago

Just made. I just transfer the PSU from the old PC that should far exceed the Power requirement of the system.

FancySnancy 1 point 1 month ago

um, you can try to bypass the power switch and turn on your PC with a screwdriver, (just google how),

have you tried launching with 1 stick of Ram/ cleaning them, it could be the issue, (also check to see if they're securely put in there)