PCPartPicker

  • Log In
  • Register

Loop filling question

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topic

nellyboy211 28 days ago

Probably a silly question. my last build I did was 10 years ago, so this is all new to me. I have a pwm cable plugged into a header which I can not get to unless I remove my radiator. My question is, if I power up my ek-xtop revo d5 PWM pump for filling with the motherboard atx power cables OFF and only the pump molex cable Connected to the PSU, will I run into any problems? I figured since it’s only a signal cable, it would be fine since no other power is connected besides pump. Thanks in advance for replies!

Comments Sorted by:

Tooth 1 Build 1 point 28 days ago

i answered your same question you already posted

nellyboy211 submitter 1 Build 1 point 28 days ago

I think you misunderstood the question. I have the bridging plug plugged in already and the motherboard has the PWM and rgb cable plugged in from the pump. The mother board has no power cables running to it. Just wanna make sure I can run the pump with the extra cables plugged into the motherboard which is off and has no power. (Wasn’t sure if any current would pass to mobo or anything would happen) I can not remove these cables unless I remove radiator. Normally I would leave all unplugged and use bridging plug and molex cable from pump plugged in. Thanks again for help

Tooth 1 Build 1 point 27 days ago

ok, i did miss understood, my bad

if you have the bridging atx plug, you are go to go with the pump cable

dont need the rgb cable at this point.

that plug prevents any other current running into your system if they were plugged into your motherboard