PCPartPicker

  • Log In
  • Register

Troubleshooting

Forum Search

Guidelines

  • Be respectful to others
  • No spam
  • No NSFW content
  • No piracy or key resellers
  • No link shorteners
  • Offensive content will be removed

Topics Start A New Topic

To aid in troubleshooting your issues, please include a permalink to your part list in your post (when applicable). Thanks!

Title Submitted By Replies Views Last Post
Temps? Ryzen 2700x 2080ti FE Okunz 4 25 1 hour ago by Okunz
Custom Water Loop Problems wknaak21 6 27 1 hour ago by wknaak21
o and x text on screen, monitors not working AstRgnlMngrDwightSchrute 8 26 6 hours ago by thunder-93
M.2 device not detected Duke_Jolly 10 74 6 hours ago by thunder-93
ASRock AB350 Pro4 Ryzen Build Boot Issue Stone710 1 19 8 hours ago by Vycyous
Installed new RAM, now BSOD on start up winona78 4 19 10 hours ago by kschendel
Display suddenly went black LeeU 5 33 14 hours ago by kschendel
Problems for 2 months ErsanTheGOAT 2 29 15 hours ago by Shakaron
Case fan problem OhhFlurry 4 36 16 hours ago by pegotico
Won’t turn on cityfanart 4 23 21 hours ago by Goodperson5656
Command Prompt Error ZFGeek 2 19 1 day ago by ZFGeek
Need help gaming issue Charlesmass99 0 18 1 day ago by Charlesmass99
Burning plastic smell Stop1333 6 43 1 day ago by ProbablyProdigy
asus rampage vi extreme motherboard none usb working nartuo4tail 9 54 1 day ago by thunder-93
What M.2 Is This? CI0N3 14 61 1 day ago by thunder-93
Gigabyte GeForce RTX 2080 OC 8GB Triple Fan Edition - Whining noise under load subtlexgaming 0 15 1 day ago by subtlexgaming
Update: Oddities with 6yo x79 rig. Voltages. Istolla 30 156 2 days ago by Rin_Itoh
PC Part Picker said these 2 are compatible but their not? Help please, had these expensive parts just sitting their for 3 yrs now Heri_Johnson 3 30 2 days ago by Zerk2012
CMX16GX3M4A1333C9 zonne 2 31 2 days ago by thunder-93
Graphics Driver Fiasco ClawMachine881 12 68 2 days ago by thunder-93
Radeon settings disappearing and memory management error dabrown12 0 17 2 days ago by dabrown12
Is my GPU making my computer lag? Apulze 6 60 2 days ago by Apulze
Laptop fan rattling after playing some demanding games TeodrosKing 2 17 3 days ago by TeodrosKing
Tested every way I could think of, pretty sure video card is bad. Anything I missed? macroidtoe 5 55 3 days ago by G_rot777
New build, solid red light on DRAM JarJarJamal 2 41 3 days ago by Marbleboot
PC mic help, hearing fan? OfMiceAndRice 0 12 3 days ago by OfMiceAndRice
HDD not working. MrUfortunate 1 30 3 days ago by firedrakes
Memory management error dabrown12 7 47 3 days ago by Vycyous
PC Help/ Stream drops frames hiredtoxiin 2 20 3 days ago by hiredtoxiin
Shutdown/Sleep issue after SSD upgrade Fizz55 0 19 3 days ago by Fizz55
Laptop fan rattling after playing some demanding games TeodrosKing 0 6 3 days ago by TeodrosKing
asus update chipset help. DeCanter 0 14 3 days ago by DeCanter
Bootable Usb Stick to SSD trouble aqua74 5 17 3 days ago by aqua74
Follow question up to RTX 2080 Stuttering and RAM MHz winona78 3 21 4 days ago by legomaster
Did I screw up my Bios? Or is it something else? wackazoa 0 24 4 days ago by wackazoa
PC will only boot without GPU installed ccmiguel25 0 20 4 days ago by ccmiguel25
Internet is making offline games lag? wil018 0 9 4 days ago by wil018
Please HELP BlackSosig 3 46 4 days ago by bucketofcrud12
Why do I have two boot options with only 1 drive installed DeCanter 2 23 4 days ago by DeCanter
Interesting Dilemma with Ryzen (1 year, each component changed) mpw90 42 114 5 days ago by mpw90
GPU broke PC 0ZWEIL0 5 22 5 days ago by legomaster
PC crashing after playing games Username289 48 158 5 days ago by legomaster
First build HELP with air flow design and fan headers. totalstranger1 2 40 5 days ago by totalstranger1
B450 MSI Pro Carbon AC 3 flashes red light Username289 3 26 5 days ago by Username289
Trying to add an additional ssd VoidlessRageGaming 3 33 6 days ago by ImperiousBattlestar
cpu BigBoiKole 2 52 6 days ago by legomaster
Surface pro 2 AI-COM_RSPN 3 29 6 days ago by treloar
Missing Motherboard Screws Boomplayer3 1 32 6 days ago by ImperiousBattlestar
New Build Won't Turn on justpayne 5 66 7 days ago by MooseTech
Experienced builders! Motherboard attachment benkimmeyer 4 33 7 days ago by MooseTech
Page
1
·
·
·