Description

I made this during black Friday, and I've been working on it ever since.

Log in to rate comments or to post a comment.

Comments

  • 51 months ago
  • 2 points

Bring the GPU up to the top PCI Lane, and rotate that rear exhaust fan so the cable gets hidden around the fan and get rid of that weird lookin cable tie pile thing. It'll look perfect then. +1

  • 51 months ago
  • 2 points

Where did you get that dragon stencil thing? Looks sweet!

  • 51 months ago
  • 1 point

thanks, I just found a piece of see through plastic and cut it into the right size, and then painted the dragon over it

  • 51 months ago
  • 1 point

I love the lights/color scheme! +1

  • 51 months ago
  • 1 point

The first slot is meant to be the main GPU slot because for your particular motherboard, it supports each PCIE slot in x16, x8/x8, x8/x4/x4 modes, which means the performance will drop with each you drop. If you want to use your setup to it's rightful potential, I suggest moving the GPU to the top slot. Other than that it's a nice looking build :)

  • 51 months ago
  • 1 point

Oh I see, I had no idea. I had in it the top spot at first, but it was blocking the MSI Logo, which I thought looked really cool, but if its going to be a noticeable difference in performance I will definitely move it up. Thanks for the tip.

  • 51 months ago
  • 1 point

What are your CPU temps with that cooler? Nice build!

  • 51 months ago
  • 1 point

Thank you, so lowest it's gotten to was 25 C on idle, and when I'm playing games it doesn't go above the mid 40's. That's the most I've done with it so far. I actually did overclock it slightly to 4.0GHz once and it stayed in the low 30's.

  • 51 months ago
  • 1 point

The light and colors really work for this, you did a good job of mixing everything the right way,

  • 51 months ago
  • 1 point

Anyone notice that GPU Sag?

  • 44 months ago
  • 1 point

How were you able to get the blue LED fans that are in the case to work? I haven't been able to find out how to make them work. Does it have something to do with my motherboard?